Teste unitário sem reconhecer classes

https://s3-us-west-2.amazonaws.com/ecode10-image/c11f2ab5-7a67-4d0b-99ee-222b892bf088TesteUnitario.jpg

Ol√° pessoal, hoje eu vou falar fato simples que aconteceu comigo e no projeto que estou trabalhando. Todo o projeto precisa se testado usando teste unit√°rio antes de enviar para o sistema, site ou software online. Se voc√™ ainda n√£o usa isso, procure sobre os assuntos unit test no Youtube, nos artigos e sites da Microsoft. √Č sempre bom usar testes unit√°rios ao inv√©s de executar sempre o sistema para poder testar uma unica funcionalidade.

Continuando o artigo, depois de criar o projeto ou se já existe no projeto principal o projeto de teste unitário, as classes podem não ser reconhecidas e não fica visível o F12 para entrar no método ou mesmo ver a classe de teste usada.

As vezes você já entrar em um projeto que já eestá em andamento e já possui os teste unitários de acordo com o que a empresa ou funcionalidade precisa. No meu caso, ao abrir o projeto, nenhuma classe dentro do projeto de teste está sendo reconhecida. O projeto não estava dando erro, mas as classes não ficavam de outra cor informando o reconhecimento, nem mesmo deixava utilizar o Go To Implementation, F12 ou coisa parecida.

Procurei por plugins mas nada fazia funcionar ou reconhecer as classes do projeto de teste unit√°rio. Todo exeemplo que eu via na Internet eu tenatava mas nenhum resolvia o reconhecimento das classes.

Problema

Reconhecer as classes dentro do projeto de teste unit√°rio.

Pesquisas

V√°rias pesquisas no Youtube, artigos, sites da Microsoft, artigos e tudo mais. Todos os exemplos mostrados nas fontes, nenhum resolvia o projeto.

Solução

Depois de muito procurar e testar, fechando e abrindo o Visual Studio, desligando e ligando o Windows, vi um coment√°rio simples na Internet falando para apagar uma pasta chamada ".vs" que fica dentro da pasta do projeto como pasta oculta.

Solicitei para abrir todas as pastas ocultas e vi a pasta ".vs". Fechei o Visual Studio e apaguei a pasta. Depois abri novamente o projeto e voltou a funcionar o reconhecimento das classes usadas dentro do projeto de teste unit√°rio.

√Č isso mesmo, basta apagar a pasta ".vs" com o Visual Studio fechado. Abra depois e tudo vai voltar a funcionar. Essa pasta √© criada novamente com as estrutura necess√°ria para tudo voltar a funcionar.

Espero ter ajudado e qualquer d√ļvida pode entrar em contato pelo site www.mauriciojunior.org.